Jalil David Salamé Messina
fde1be66d9
All checks were successful
/ check (nvimDev) (push) Successful in 5s
/ check (nvimHeadless) (push) Successful in 3s
/ check (nvimNoBundledBins) (push) Successful in 4s
/ check (nvimNoLsp) (push) Successful in 4s
/ check (nvimNoTSGrammars) (push) Successful in 4s
/ check (treefmt) (push) Successful in 2s
/ build (audiomenu) (push) Successful in 1s
/ build (docs) (push) Successful in 1s
/ build (jpassmenu) (push) Successful in 1s
/ build (nixosConfigurations.vm.config.system.build.toplevel) (push) Successful in 1s
/ build (nvim) (push) Successful in 1s
/ report-size (push) Successful in 4s
Wezterm is broken in current nixpkgs unstable and stable due to a fractional scaling issue in wayland.
23 lines
521 B
Nix
23 lines
521 B
Nix
{ inputs, ... }:
|
|
{
|
|
# Add unstable packages to overlay
|
|
flake.overlays.unstable =
|
|
final: prev:
|
|
let
|
|
unstablePkgs = inputs.unstable.legacyPackages.${prev.stdenv.hostPlatform.system};
|
|
in
|
|
{
|
|
# Get unstable packages
|
|
unstable = unstablePkgs;
|
|
|
|
# Update vim plugins with the versions from unstable
|
|
vimPlugins = prev.vimPlugins // unstablePkgs.vimPlugins;
|
|
|
|
# Get specific packages from unstable
|
|
inherit (unstablePkgs)
|
|
gitoxide
|
|
jujutsu
|
|
;
|
|
};
|
|
|
|
}
|