Jalil David Salamé Messina
09cc4e6110
All checks were successful
/ check (nvimDev) (push) Successful in 5s
/ check (nvimHeadless) (push) Successful in 3s
/ check (nvimNoBundledBins) (push) Successful in 5s
/ check (nvimNoLsp) (push) Successful in 5s
/ check (nvimNoTSGrammars) (push) Successful in 5s
/ check (treefmt) (push) Successful in 2s
/ build (audiomenu) (push) Successful in 1s
/ build (docs) (push) Successful in 1s
/ build (jpassmenu) (push) Successful in 1s
/ build (nixosConfigurations.vm.config.system.build.toplevel) (push) Successful in 2s
/ build (nvim) (push) Successful in 2s
/ report-size (push) Successful in 4s
Its causing errors sadly T-T
52 lines
1.7 KiB
Nix
52 lines
1.7 KiB
Nix
{ inputs, ... }:
|
|
{
|
|
flake.overlays.nixvim = inputs.nixvim.overlays.default;
|
|
|
|
perSystem =
|
|
{ lib, system, ... }:
|
|
let
|
|
nixvimLib = inputs.nixvim.lib.${system};
|
|
nixvim = inputs.nixvim.legacyPackages.${system};
|
|
testNvimModule = nixvimLib.check.mkTestDerivationFromNixvimModule;
|
|
nvimModule = extraConfig: {
|
|
pkgs = inputs.unstable.legacyPackages.${system};
|
|
module = {
|
|
imports = [ ../nvim/standalone.nix ];
|
|
config = lib.mkMerge [
|
|
{ performance.combinePlugins.enable = true; }
|
|
extraConfig
|
|
];
|
|
};
|
|
};
|
|
moduleDev = nvimModule { };
|
|
moduleHeadless = nvimModule { jhome.nvim.dev.enable = false; };
|
|
moduleNoLsp = nvimModule { jhome.nvim.dev.bundleLSPs = false; };
|
|
moduleNoTSGrammars = nvimModule { jhome.nvim.dev.bundleGrammars = false; };
|
|
moduleNoBundledBins = nvimModule {
|
|
jhome.nvim.dev = {
|
|
bundleLSPs = false;
|
|
bundleGrammars = false;
|
|
};
|
|
};
|
|
in
|
|
{
|
|
# Check standalone nvim build
|
|
checks = {
|
|
nvimDev = testNvimModule moduleDev;
|
|
nvimHeadless = testNvimModule moduleHeadless;
|
|
nvimNoLsp = testNvimModule moduleNoLsp;
|
|
nvimNoTSGrammars = testNvimModule moduleNoTSGrammars;
|
|
nvimNoBundledBins = testNvimModule moduleNoBundledBins;
|
|
};
|
|
|
|
# Nvim standalone module
|
|
packages = {
|
|
nvim = nixvim.makeNixvimWithModule moduleDev;
|
|
# Smaller derivations
|
|
nvim-headless = nixvim.makeNixvimWithModule moduleHeadless;
|
|
nvim-small = nixvim.makeNixvimWithModule moduleNoBundledBins;
|
|
nvim-no-ts = nixvim.makeNixvimWithModule moduleNoTSGrammars;
|
|
nvim-no-lsps = nixvim.makeNixvimWithModule moduleNoLsp;
|
|
};
|
|
};
|
|
}
|