Instead only import the nixos/hm/nixvim module. This _should_ reduce rebuilds.
31 lines
711 B
Nix
31 lines
711 B
Nix
{ self, inputs, ... }:
|
|
{
|
|
# FIXME(25.05): this version of HM should have the flake module
|
|
# imports = [ inputs.home-manager.flakeModules.home-manager ];
|
|
|
|
flake.homeModules =
|
|
let
|
|
defaultModules = [
|
|
inputs.nixvim.homeManagerModules.nixvim
|
|
self.nixvimModules.homeManager
|
|
../module/hm
|
|
];
|
|
nixos = {
|
|
imports = defaultModules;
|
|
};
|
|
standalone = {
|
|
imports = defaultModules ++ [
|
|
inputs.stylix.homeManagerModules.stilyx
|
|
(
|
|
{ config, ... }:
|
|
{
|
|
stylix.image = config.jhome.sway.background;
|
|
}
|
|
)
|
|
];
|
|
};
|
|
in
|
|
{
|
|
inherit standalone nixos;
|
|
};
|
|
}
|