Some checks failed
/ check (nvimDev) (push) Failing after 1s
/ check (nvimHeadless) (push) Failing after 1s
/ check (nvimNoBundledBins) (push) Failing after 1s
/ check (nvimNoLsp) (push) Failing after 1s
/ check (nvimNoTSGrammars) (push) Failing after 1s
/ check (treefmt) (push) Successful in 3s
/ check-renovaterc (push) Successful in 3s
/ build (audiomenu) (push) Has been skipped
/ build (docs) (push) Has been skipped
/ build (jpassmenu) (push) Has been skipped
/ build (nixosConfigurations.vm.config.system.build.toplevel) (push) Has been skipped
/ build (nvim) (push) Has been skipped
/ report-size (push) Has been skipped
This is only available in the unstable HM branch, so we are stuck with the non flake-parts version
35 lines
682 B
Nix
35 lines
682 B
Nix
{ inputs, ... }:
|
|
let
|
|
overlays = builtins.attrValues inputs.self.overlays;
|
|
in
|
|
{
|
|
imports = [
|
|
inputs.treefmt-nix.flakeModule
|
|
|
|
./devshells.nix
|
|
./docs.nix
|
|
./example-vm.nix
|
|
./nixos-modules.nix
|
|
./home-modules.nix
|
|
./nixvim-modules.nix
|
|
./overlays.nix
|
|
./scripts.nix
|
|
];
|
|
|
|
perSystem =
|
|
{ system, ... }:
|
|
{
|
|
_module.args.pkgs = import inputs.nixpkgs { inherit system overlays; };
|
|
|
|
# Setup formatters
|
|
treefmt = {
|
|
projectRootFile = "flake.nix";
|
|
programs = {
|
|
nixfmt.enable = true;
|
|
rustfmt.enable = true;
|
|
statix.enable = true;
|
|
typos.enable = true;
|
|
};
|
|
};
|
|
};
|
|
}
|